Jump to content
studiot

Reset wrong keyboard

Recommended Posts

I have gained an old Acer travelmate laptop that has some useful stuff on it.

But I think the previous owner may have used it with a plug in keyboard.

The problem is that most of the keys present the correct letters when pressed but some are off the wall.
For instance the 'o' appears as a 6.

The microsoft onscreen keyboard works just fine, but is cumbersome.

Device manager (windows XP) reports that there is a standard 101/102 keyboard that is 'working fine'
No other keyboard is shown.

I uninstalled it and let it find and reinstall the keyboard, but the problem remains.

 

Any suggestions welcome.

Edited by studiot

Share this post


Link to post
Share on other sites

1) verify whether plugging external keyboard fixes issue (language and regional settings will affect both built-in and external keyboard)

2) try running laptop in safe-mode, command-line mode, and BIOS, to check if issue is still present in them.

3) what is exact model name? (start > dxdiag.exe will show it)

4) Find your laptop model on e.g. https://www.ebay.com/b/Acer-Laptop-Replacement-Keyboards-for-TravelMate/31568/bn_5800086

 

Edited by Sensei

Share this post


Link to post
Share on other sites
44 minutes ago, Ghideon said:

Quick Idea; Is numlock key working? See last image here: http://www.ergovancouver.net/Problems-Numeric_Keypad.htm

This laptop has no numeric keyboard.

It is an Acer Travelmate 4051 LMi.

Here is a sceenshot of typing the top letter line with both the laptop and an external usb keyboard connected.

The usb kb. is OK

acer1.JPG.9560c9a5abdb88990385a41f4b6cf83a.JPG

Share this post


Link to post
Share on other sites
1 minute ago, studiot said:

This laptop has no numeric keyboard.

I know, but in some cases the computer can emulate a numeric keypad by using some of the letters. That's why I posted a reference to a keyboard where the letter 'O' will result in the number 6. What happens for J,K,L? So my guess is that we need to find the setting that disables the virtual numeric keypad for the Acer Travelmate.

 

image.png.75299116e8beef65f565c75e83ba693a.png

 

Share this post


Link to post
Share on other sites

Form this pic of a TravelMate keyboard, it looks like Fn+F11 might do it:

acer-travelmate-p648-w-g12.jpg

Share this post


Link to post
Share on other sites

Here is why I suspected the num lock key to be a problem, unfortunately wrong model but maybe close enough:

The embedded numeric keypad functions like a desktop numeric keypad. It is indicated by small characters located on the upper right corner of the keycaps. To simplify the keyboard legend, cursor-control key symbols are not printed on the keys.

Desired access

Num lock on

Num lock off

Number keys on embedded keypad

Type numbers in a normal manner.

 

Cursor-control keys on embedded keypad

Hold <Shift> while using cursor-control keys.

Hold <Fn> while using cursor-control keys.

Main keyboard keys

Hold <Fn> while typing letters on embedded keypad.

Type the letters in a normal manner.

From acerrepairblog.us/travelmate-4060

Edited by Ghideon
X-posted with @Strange who has posted a better image.

Share this post


Link to post
Share on other sites

Thanks guys, I will try out your ideas and report back.

A correction, the keyboard has a normal line of numberers above the querty line. It just has no separate number pad.

Sorry for mixing up pad and board.

 

Curioser and curioser.

I tried Sensei's safe mode suggestion.

This has 3 users, Studiot, the former Owner and the built in administrator.

It is the studiot account that is duff, the keyboard operates normally on the other two, both in safe and normal modes.

The studiot account misbehaves as shown in both safe and normal modes.

Edited by studiot

Share this post


Link to post
Share on other sites
26 minutes ago, Ghideon said:

Here is why I suspected the num lock key to be a problem, unfortunately wrong model but maybe close enough:

I just came back to post something about the three modes, but it would have been from memory so I'm glad you found that!

Share this post


Link to post
Share on other sites
22 minutes ago, studiot said:

I tried Sensei's safe mode suggestion.

This has 3 users, Studiot, the former Owner and the built in administrator.

It is the studiot account that is duff, the keyboard operates normally on the other two, both in safe and normal modes.

The studiot account misbehaves as shown in both safe and normal modes.

Log in to former Owner account and/or admin, open keyboard, language, regional settings. Remember them (or easier make screen-shots).

Then log off and log in to your account, and compare them.. if there are differences, set them to the same as on working accounts, and check again.

 

Edited by Sensei

Share this post


Link to post
Share on other sites
16 minutes ago, studiot said:

It is the studiot account that is duff

Hint from community.acer.com, unclear if it applies only one specific user or all accounts:

In Regedit
Navigate to registry key HKEY_USERS\Default\Control Panel\Keyboard
check if “InitialKeyboardIndicators” has Value data = 2 (If so, the numeric keypad is "on" when booting)

Maybe it is possible, via this or a similar registry key (see bold above), to set num lock to "on" for a specific user? If so, is that what has happened to the studiot account? I'm using a MacBook so I can't view a registry to verify my speculations. 

Share this post


Link to post
Share on other sites

Solved

 

Actually it is not the number lock but following all you guys' helpful hints was brilliant.

 

This laptop has a 'pad'lock in addition to the number lock as well as a little light for each.

The padlock toggle is fn + f10.

 

And yes it also has miniscule  blue letters on the relevant key edges.

 

So thanks and +1 all round for steering me in the right direction.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.