Jump to content
Sign in to follow this  
eruheru

Sync. out of range!!!!

Recommended Posts

i just installed ubuntu (hoary hedgehog) and when i start up the computer it says "Sync. out oF Range" in a red box that moves across the screen. when i press the power button it goes back to login for a few seconds, then shuts down. How can i easily fix this? i know it has to do with the monitor refresh rate, but imi not sure exactly what to adjust. thank sin advanced

Share this post


Link to post
Share on other sites

err, well, going on what you said about the problem being the refresh rate:

 

1) Can you use the buttons on the monitor itself to alter the refresh rate

 

2) Have you still got Windows or some such to boot into and edit the refresh rate that way

 

Otherwise I'm not really sure. Is your graphics card compatable with the version of ubuntu you are using?

Share this post


Link to post
Share on other sites

(Oops)

im going on what i heard on other responses in different forums

on linuxquestions.org:

well, you have to provide correct refresh rates for your monitor.

your xorg is not correctly configured. best you can do is to try to

connect in a root console. I don't know about how to do that

in ubuntu, but if someone can tell you here, do that, than when

you are root (superuser) type 'xorgconfig', hit the enter key

and answer the questions you'll see on screen.

have your monitor specs ready and when prompted, enter them.

hopefully at reboot you will avoid this annoying message.

 

and on ubuntuforums.org:

You need to edit the "Monitor" section of your xorg.conf file.

Make sure that the HorizSync and VertRefresh values are correct.

 

At the command line enter this to edit the file by hand:

 

Code:

 

$ sudo nano -w /etc/X11/xorg.conf

 

the latter comes up with as an unrecognized file command. and im not sure what to do.

Share this post


Link to post
Share on other sites

Well I can't help on this, so keep trying ubuntuforums & linuxquestions, unless someone else here can give you some help.

Share this post


Link to post
Share on other sites

if you press:

 

ctrl - alt - F1

 

That will change the tty you're using and should drop you to a command line that with any luck will work, if you log in using your username and password.

 

This account if it's the account you created on install has sudo privaledges which means if you wish to execute commands as root use

sudo command parameters

 

type the following:

 

ls /etc/X11/[code]

 

And make sure xorg.conf is listed.

 

Note that all the commands and file paths/names are case sensitive.

 

What graphics card are you using?

Share this post


Link to post
Share on other sites

Look in your /etc/X11/xorg.conf. WHen you installed it it's gotten some wrong numbers for your sync. Look in the file for something like this

Section "Monitor"
       Identifier      "Generic Monitor"
       Option          "DPMS"
       HorizSync       28-64
       VertRefresh     43-60
       Modeline        "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Look in your monitor manual or call customer support and ask for the horizonral and virtical sync. Put in the numbers.

 

PS: If you have probablems with screen resolutions we can help you there as well.

Share this post


Link to post
Share on other sites

i was able to figure out were to configure it from. however i dont have the booklet telling me the specs about my computer in a lot of detail. are their any sites that have this availible? its a dell dimension 2400. and is there a site that could get the horizontal and vertical sync rate?? thanks.

Share this post


Link to post
Share on other sites

You're more likely to get a result if you get the model number of your screen (should say it on the screen somewhere) and then doing internet searches for it.

Share this post


Link to post
Share on other sites

Your best bet is looking at the manufactures website to see if they publish the specs online (I know CTX do)

Share this post


Link to post
Share on other sites

Yeah, any website which gives a detailed specifications is worth a try.

 

Try doing a google search for your screen and refresh rate or specifications or something.

Share this post


Link to post
Share on other sites

how do i find out what specefic model number the moniter is? i know its a dell and the manufacture date on the back is in 2001 if it helps.

Share this post


Link to post
Share on other sites

Try looking on the back of the monitor.

 

Desktop > right click > properties > settings tab > advanced > monitor tab

although that might be useless

 

I dunno, even in Device Manager (control panel > administrative tools > computer management > device manager (on the side) > then under monitors) mine is still referred to as Plug and Play Monitor... which is kinda useless.

 

See if you have any of the original documentation.

Share this post


Link to post
Share on other sites

Is it just me or is the problem that he cant start the X server? How would right cliking a desktop that isn't there help him? Plus what kind of desktop uses those menus? I know gnome and KDE don't. Honestly 5614 what are you talkign about? I have a remote feeling that those are windows stuff.

 

Anyway, if you cant find anything at your company's website call customer support. I had to do that once a while ago. It normally gets the synx ranges from the monitor but if you run the wizard it wont search for it and instead asks you (which normally ends up stumping the user). The guy on the other end may seem kind of confused but they'll eventually find the numbers.

 

If you want the graphical wizard I was talking about, run sudo dpkg-reconfigure xserver-xorg. Run it with -phigh if you just want to "fix your screen resolution" or switch to a different driver.

Share this post


Link to post
Share on other sites

i was able to get all the specs i needed for xorgconfig, but it still didnt work. i think theres something going wrong when the file writes at the end. how do i get to root?

Share this post


Link to post
Share on other sites

oh. Root in ubuntu. You have to use the sudo command.

 

IE, if you want to run dpkg-reconfigure xserver-xorg you need to use

sudo dpkg-reconfigure xserver-xorg

The password for root is the same as your log-in password. To get it root@ubuntu $] or whatever type sudo su.

 

PS: A search would have quickly answered your question. This is one of the main features of Ubuntu.

Share this post


Link to post
Share on other sites

i used sudo xorgconfig and now its displaying "i cannot start the X server

(your graphical interface) It is likely that it is not set up corectly."

Share this post


Link to post
Share on other sites

Uh, yeah. It's not configured right. To configure it you have two options.

 

A) Try plugging in your screen syncs in the xorg config

B) run dpkg-reconfigure xserver-xorg

 

That will inevitably ask you for the numbers as well. Try A first because everything may be configured properly except the sync ranges. If that doesn't work go to B. Shouldn't take but ten minuits tops.

 

Have fun :)

Share this post


Link to post
Share on other sites

That will inevitably ask you for the numbers as well. Try A first because everything may be configured properly except the sync ranges. If that doesn't work go to B. Shouldn't take but ten minuits tops.

 

unless you don't know all the configurations. I think we ran into a problem they asked for the video card's bus identifier... which we didn't know. Is there perhaps some place we could find this out?

 

edit: I didn't see my brother's post there.

Share this post


Link to post
Share on other sites

Uh.. I have no idea. Try this website:

 

http://linuxquestions.org

 

You can try installing the video drivers first. If it's nvidia than just type

sudo apt-get install nvidia-glx

...

apt-get install nvidia-settings

ATI:

apt-get install xfree86-driver-fglrx

 

If it asks to uninstall X windows you might want to hold off. It'd be better to get it working before installing a brand new X.org / dri. But then again nvidia has it's own "wizard" and it might figure things out for you. If it does take off x-windows install xfree86-common. Alternatively type apt-get install xwindows and it'll list all the diferent xwindows to chose from.

 

 

edit:

Btw you don't need to reboot or anything. After you run a wizard or edit the file just type

 

startx (or if permission's denied startx -- :1/2/3)

 

You might find it useful to hold down ctrl-alt-F1/2/3/4 etc to move between terminals.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.