Sign in to follow this  
iNow

Sandbox: Merge Post Test

Recommended Posts

Post number 2 - Submit

Should merge

Share this post


Link to post
Share on other sites

Post number 3 - Submit

Should also merge

Share this post


Link to post
Share on other sites

Test one

 


Merged post follows:

Merged post

 

test

 


Merged post follows:

Here it is

 

In order to merge posts you have to manually add the code:

 

[mp](Insert Text Here)[/mp]

 

To the top of the second post you are wishing to merge to the first post. You can find in in the "other styles" drop down menu entitled "Merged Post Divider"

 

Ignore this it appears to be working now, however, it is that code which creates the little divider thing.

Share this post


Link to post
Share on other sites

T1

 

T2

 

T3

 

T1

 

T2

 

T3

 

End Test.

 

Thanks, Capn. Looks like your update allowed the auto merge to work again. However, it is still currently missing the separator. DJBruce was kind enough to provide the code in his post. Can that be added back to the auto-merge?

 

 


Merged post follows:

(Insert Text Here)

Share this post


Link to post
Share on other sites

Unfortunately there's no easy way to do that. If you're in the habit of using the feature, be sure to quote posts so it's clear who you're talking to, or insert an hr tag or the merged posts tag manually.

Share this post


Link to post
Share on other sites

Begin quote test

 

Test 1 Syntax: Quote=iNow

End Test 1

 

Test 2 Syntax: Quote='iNow'

End Test 2

 

Test 3 Syntax: Quote Name=iNow

End test 3

 

Test 4 Syntax: Quote Name='iNow'

End test 4

Edited by iNow

Share this post


Link to post
Share on other sites

There's a bug when you make multiple merged posts with quotes in them. Dunno if that's what you're testing. It'll be fixed in the next version of IPB.

Share this post


Link to post
Share on other sites

I've been trying to figure out how to manually type in who made the quote... It looks like test 4 above worked fine.

 

Syntax: Quote Name='iNow"

 

 

I only used the merge post test thread so I didn't waste space with another one.

The tests are distinct from each other and unrelated. Thanks, dude.

 


I'm not sure why, but I can't associate the quotes in this post with me and Jackson:

http://www.scienceforums.net/topic/50023-congress-to-obama-the-atm-is-closed/page__view__findpost__p__554880

 

I tried to edit it from it's current state... Everywhere I had typed a manual quote tag, I went back in to update where I'd originally typed "Quote=iNow" and replace it with "quote name='iNow' "

 

Then, when I try to save the post, it tells me that the number of open quote tags and close quote tags don't match... Except... The tag number is exactly the same... All I did was add the quote name function to associate the quote with who said it. Hmm.

 


Here's the exact text of the message (again, i didn't change the number of tags, just their structure):

 

The number of opening quote tags does not match the number of closing quote tags.

Edited by iNow

Share this post


Link to post
Share on other sites

Hmm. It may be the same bug as I reported regarding merging. We'll see if it's fixed in the next version.

 

If you continue to encounter it, try making a reduced testcase -- remove bits from the post until you come up with the smallest possible example that causes the problem. I can report further bugs to the IPB guys, as they're very quick to fix them. (Most of my reported bugs have been fixed in just a day or two...)

Share this post


Link to post
Share on other sites

[quote name='Cap'n Refsmmat' date='16 July 2010 - 07:26 PM' timestamp='1279330018' post='554894']
If you continue to encounter it, try making a reduced testcase -- [/quote]
Ok.

[quote name='iNow']Pretend quote from iNow[/quote]
The above should show my name in the quote from field, not just a blank quote.


[quote name='Cap'n Refsmmat' date='16 July 2010 - 07:26 PM' timestamp='1279330018' post='554894']remove bits from the post until you come up with the smallest possible example that causes the problem. [/quote]
[quote name='iNow']Second quote test from iNow which should also show my username in the quote header[/quote]
The above should also have my username.

[quote name='Cap'n Refsmmat' date='16 July 2010 - 07:26 PM' timestamp='1279330018' post='554894']I can report further bugs to the IPB guys, as they're very quick to fix them. (Most of my reported bugs have been fixed in just a day or two...)
[/quote]

Cheers.

 

I can't even submit the post now with the above manual quote associations. Here's the error from this post:

 

The number of opening quote tags does not match the number of closing quote tags.

Edited by iNow

Share this post


Link to post
Share on other sites

I see. And that was all as one post, not as a merged post?

 

I'll add that to my previous bug report.

Share this post


Link to post
Share on other sites

I see. And that was all as one post, not as a merged post?

Correct. Thanks.

 

Kinda pisses me off when I can't submit a post due to unequal open and quote tags when I can quite clearly see and count that I have the same number of open tags as I do close tags. :unsure:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this