Jump to content
Sign in to follow this  
1veedo

Getting Windows to boot off the secondary slave

Recommended Posts

I have Windows Server 2003 installed on it's own personal HD and to boot it I've always physically moved the master cord from my main OS HD to the Windows HD, everything cable select. I have 3 hard drives but only two would be hooked up at a time.

 

But now I've decided to permanently hook it up on the same cord as my CD/DVD burner. It works fine with the motherboard, I can mount the partition and everything (which means I can get native DLLs for wine off 2003 and not my XP computer across the network... ), but I cant seem to get it to boot.

 

I have a floppy with smart boot manager but it cant see it. My BIOS wont boot it. And grub has not been able to do it. Grub doesn't seem to see it though. The superblock is /dev/hdd1 and translated to grub language that should be hd3,0 but *tab reveals that I can only set root up to hd2. I figure it might be skipping hdc, which is my dvd, but it may be that it just cant see hd3.

root=(hd2,0)
unhide=(hd2,0)
rootnoverify=(hd2,0)
chainloader +1
makeactive
boot

And it hangs.

 

Any ideas?

Share this post


Link to post
Share on other sites

Can you not add a line into the boot.ini file to give you a dual boot option?

Share this post


Link to post
Share on other sites

Windows doesn't like booting for a drive that isn't primary. I have a setup of primary (gentoo) secondary (winxp) and used something like this in grub:

 

1 map (hd0) (hd1)

2 map (hd1) (hd0)

3 rootnoverify (hd1,0)

4 chainloader +1

5 boot

 

http://www.gnu.org/software/grub/manual/html_node/map.html

 

CD-Roms etc don't show up as hdx in grub. Hope that helps

Share this post


Link to post
Share on other sites

Great, works like a charm. I think it's funny I tell it to boot and it complains cause it's not on 64bit hardware. Too bad qemu cant emulate 64, I could have Win2003 running inside Linux.

 

I cant seem to get that to show up in menu.lst though

title Windows
map (hd0) (hd2)
map (hd2) (hd0)
rootnoverify (hd2,0)
chainloader +1
boot

I type exactly that from the command line and it works.

Share this post


Link to post
Share on other sites

oops, it does work. qemu I guess wasn't getting the menu addition or someting but I was just in Windows, and now back to Linux, for the first time with out physically moving hard drives around.

 

Thanks.

Share this post


Link to post
Share on other sites

It matters where you put the hard drive in the computer? I think the CDROM is the primary master in one of my computers... I thought the only problem came up when you hooked your CDROM and CD Burner on the same cable, making errors more common in burning. So it matters where you put the hard drive?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.