Jump to content



Recommended Posts

Ive recently been having problems with bittorrent, it seemed that my ISP was choking bandwidth on 6881, so i changed to 40,000, and then recently to 65535...



My point is that switching helped breifly, but now whenever i start a torrent, my internet connection cuts out, completely... (that was the problem i had with the other ports too...) ... the problem used to go away when i changed ports, but not anymore.


Id Like to point out that i used BT for about 2 years on the same ISP with no problems, this is a fairly recent problem, and none of my hardware has changed, except me changing the Port Triggering on my router so it stands to reason the problem MUST be the ISP...


I assumed that my ISP had blacklisted a whole portrange so i emailed them asking for a list of them. i got this reply


Dear James,






We have no control over your ports and therefore do not block any. If you are wanting to check open ports on your PC I would suggest you use: http://www.dslreports.com/scan












Im sure thats just a blow off, as im nearly 100% sure thats not true, and ISPs


DO have control over ports and they do indeed blacklist/choke ports.


So can any of you confirm this for me?


I dont want to write an indignant email back, only to be proved wrong... but i think hes just lying to me.

Link to comment
Share on other sites

well YT, if thats so, whats the deal with this?




Why ports are blacklisted and what to do about it


ISPs have been increasingly reducing the available bandwidth for P2P users on the standard file-sharing port ranges. You may find you need to keep changing your port on a regular basis. This is normal, and a port change should sort you out if this is indeed what is happening. And please keep in mind that after any port change, and stopping and restarting any torrent, it may take up to half an hour or more for the benefits to become noticeable. So please try not to panic when things do not improve immediately. This is normal. :)


Im not saying your wrong, i just want clarification.

Link to comment
Share on other sites

i tried uTorrent but to no avail...


i have made a little bit of headway though.


The problem is that currently whenever i start a torrent my internet connection dies and i have to reboot the router.


it MAY be a problem with the router, cos it seems that it only dies when i get BT to use one of the ports that ive set the router to forward.


Also, now for some inexplicable reason, my routers web interface crashes everytime i try to change the ports.



SOMETING is broken somewhere, and im going to get to the bottom of it.


It seems odd for the router to just decide its going to be broken out of the blue ...

ahh well. Time will tell.

Link to comment
Share on other sites

Well they may not "choke" the ports but if lots of people use the ports then they will be choked through no fault of the ISP. This is especially true for cable which is why most Cable ISPs dont like a lot of things -- servers, p2p, etc.

Link to comment
Share on other sites

Like 1veedo said they can become congested if one ISP has to run a lot of data through one port.


YT as your entire internet activity goes through your ISP they can stop you from having access. I'm not saying they do. I'm not saying they ever have. I'm saying they can if they wanted to. This will always be the case as they are (ie. they control) your gateway to the WWW.


So I'm not entirely with you on your problem. BT was going slowly so you switched ports. You could do this every now and again.

Now what port is it on?

You start a torrent and lose all internet conectivity?

How do you reconnect?

Who is your ISP?

Have you tried resetting BT/router to default, so back to 6881?


Also you know that BT can use ports after 6881, so whilst 6881 is the default, if it cannot be accessed then BT can use any port up to 6889. Your BT client also needs outbound access on port 6969


[edit]Oh, missed what you said about it seemingly being the router. So now you can't change the ports on your router? What value is it? Sounds like your router is a bit broke if you can't change the port options. Maybe try disconnecting all power to it and reseting it.


And you are using TCP ports... not UDP.

Link to comment
Share on other sites

it`s NOT a "blow off"' date=' they do Not have Any control over the ports you access to a remote server, only those to them (BT) directly.

you`re a free agent with regards to a 3`rd party server.[/quote']


ISP's have blocked traffic going to or coming out of port 25 from large sections of their customers (usually universities) in an attempt to cut down on spam (port 25 being the email program's port), and there has been talk of the ISP's that also own phone companies blocking ports associated with voice-over-internet programs (not sure what came of that, tho).


Might it be worth turning off any software/router firewalls that you have to see if that's a problem (not sure if it could be tbh).

Link to comment
Share on other sites

Ok, 5614, ill try restetting the router completely.


Cap'n, i confess i thought the same for a moment, but i never used to have any problems whatesoever, in azureus you can limit the outbound and inbound connections, i set them both to 1, and still had the same problem, so thats not it :)


Dak, mmm, i suspected as much ... thnx

Link to comment
Share on other sites

It's most likely the router. A lot of them can't handle the level of traffic BitTorrent throws at them, and so they lock up.


I thought routers were built for routing data, hence should be able to handle heavy traffic(although i suspect it would be no match for a busy road :D)

Link to comment
Share on other sites

d22k there are ways you can test to see if a port is blocked. Try and send some data using that port (use a different program not BT) and see what happens.


If there's someone you know who would know if ports had recently been blocked at your uni then talk to them. If it used to work and it is not a prob with your computer/router then it sounds like a recent change.


Does BT still not work on any port?


But you can use those ports for other things?


If so doesn't that suggest an issue with BT?

Link to comment
Share on other sites

well unless things have changed since I was a BT customer, we never had any problems with accessing ports via scanner/sniffers, the only Blocked ports were those set at the target end, and although I left BT because they capped the usage time and accused me of being on the net 16+ hours a day (on dial-up) which was impossible as I was asleep for 8 hours and at college for another 8, 16 hours online would have been difficult!

I did dispute this but in typical British Telecom style, they just cut me off anyway. non the less, port scanners always turned up a result on a remote system even if it was a negative one, it was never blocked though???

Tiscali`s the same, a port scan works fine too, I`ve never heard of an ISP blocking remote ports (other than their own)?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.