Jump to content

Updated to latest forum software


Recommended Posts

Hello all -- I hope you are doing well in these odd times and keeping safe.

This morning I've applied an update to our forum software, which obviously brings a few visual updates and changes in comparison to the older version. This was necessary to ensure we stay up to date with the latest security features and patches. However, from a functionality perspective, I believe this will mostly remain unchanged.

Please do let us know in this thread if you have any issues with the site, and I'll continue to monitor the site for problems.

Link to post
Share on other sites

Hi Dave, just checking if Tex still works.


[math]This\quad is\quad a\quad Test[/math]


[math]\oint\limits_v {{r^n}dv} [/math]


[math]\begin{array}{*{20}{c}}
   {{a_{11}}} & {{a_{12}}} & {{a_{13}}}  \\
   {\frac{{\partial \Omega }}{{\partial u}}} & {\frac{{\partial \Omega }}{{\partial v}}} & {\frac{{\partial \Omega }}{{\partial w}}}  \\
   {\frac{{{\partial ^2}\Omega }}{{\partial {u^2}}}} & {\frac{{{\partial ^2}\Omega }}{{\partial {v^2}}}} & {\frac{{{\partial ^2}\Omega }}{{\partial u\partial v}}}  \\
\end{array}[/math]

 

Update since no edit available

 

Still have to use the refresh to get the blighter to display.

Also the font is not longer crisp and clear on my screen.
Is this an aliasing problem ?

40 minutes ago, Curious layman said:

Nice, I like it, but there's a big grey circle over the like button. Is this deliberate or is it my computer? 

Also, can't sign out and there's no edit button. 

Quote function appears to be similar

You can use its auto merge function to update as I did until the edit button is restored.

Link to post
Share on other sites

Admin likely needs to configure the allowed edit window (how longer after post submission edit button remains available)

EDIT: Disregard. Edit button is part of the drop-down options on top-right of the post. Looks like an eclipses. 

Edited by iNow
Link to post
Share on other sites

Has anyone figured out where to find notifications, replies, etc. or how to get to our user profiles via mobile phone within the new software UI?

Also... lol on my previous post. Ellipse... stupid autocorrect 

Link to post
Share on other sites

@Dave if you will compare computer version of the forum with mobile version of reply UI panel, you should see there are missing buttons e.g. subscript and superscript icons in mobile. Is it fixable?

Link to post
Share on other sites

Also missing notifications, link to profile, mark site as read, etc on mobile version 

In the recent activity area where new posts appear in the search results, clicking the url for the thread title used to take users to the last post read / oldest unread post. Clicking it now takes you to post #1 on page #1 and you then have to scroll to find the unread posts (even on threads with 37 pages).

Link to post
Share on other sites
On 2/13/2021 at 12:22 PM, studiot said:

Still have to use the refresh to get the blighter to display.

Also the font is not longer crisp and clear on my screen. Is this an aliasing problem?

On the first point, I've added a small addition to the script to reload MathJax once content changes in-browser, so edits and quick replies should now show you the rendered math once they are submitted.

 

1 hour ago, Sensei said:

@Dave if you will compare computer version of the forum with mobile version of reply UI panel, you should see there are missing buttons e.g. subscript and superscript icons in mobile. Is it fixable?

Looks like they were removed from the toolbar, but I have re-added those for you now. If there are others that are desperately wanted then let me know and I can add those, too.

 

26 minutes ago, iNow said:

Also missing notifications, link to profile, mark site as read, etc on mobile version 

In the recent activity area where new posts appear in the search results, clicking the url for the thread title used to take users to the last post read / oldest unread post. Clicking it now takes you to post #1 on page #1 and you then have to scroll to find the unread posts (even on threads with 37 pages).

On mobile, Mark Site as Read is available if you click on the three lines at the top-right corner of the toolbar. This also shows your profile information if you need to edit it. Not sure about the recent activity; can't see an obvious setting for that within the control panel, but perhaps this is just a bug and can be fixed in a later release.

Link to post
Share on other sites
9 minutes ago, Dave said:

click on the three lines at the top-right corner of the toolbar.

That gets it done. Many thanks, Dave. Cheers 🥂 

Link to post
Share on other sites
16 minutes ago, Dave said:
On 2/13/2021 at 12:22 PM, studiot said:

Still have to use the refresh to get the blighter to display.

Also the font is not longer crisp and clear on my screen. Is this an aliasing problem?

On the first point, I've added a small addition to the script to reload MathJax once content changes in-browser, so edits and quick replies should now show you the rendered math once they are submitted.

Here goes, fingers and toes crossed.


[math]\frac{{dy}}{{dx}}\frac{{\Delta y}}{{\Delta x}}\frac{{\delta y}}{{\delta x}}\frac{{{\partial ^2}\Omega }}{{\partial {u^2}}}\frac{{{\partial ^2}\Omega }}{{\partial {v^2}}}\frac{{{\partial ^2}\Omega }}{{\partial u\partial v}}\mathop {\lim }\limits_{\delta x \to 0} [/math]

Edit using my newly found edit function.

BINGO.

Thanks, a Sunday treat.

 

Edited by studiot
Link to post
Share on other sites
5 minutes ago, Curious layman said:

Lol 😁 

Im on iPad. I hit the circle and no matter where I hit it, it goes green. 

Not that I want to down vote anyone, just curious. 

Looks like you need someone with an iPad. Just checked on my Android phone and the grey circle with a heart in it is there and I can choose to vote up and down.
 

1 minute ago, StringJunky said:

Looks like you need someone with an iPad. Just checked on my Android phone and the grey circle with a heart in it is there and I can choose to vote up and down.
 

If you have an iPhone, have a look on that and if it's the same as the iPad, it's probably an Apple software issue.

Link to post
Share on other sites
On 2/14/2021 at 11:08 PM, swansont said:

What does the hand at the bottom of an avatar mean? I only see it on newer members. Is that the connection?

If you will hover by mouse pointer that little icon on PC desktop/laptop machine there will appear bubble help with details "(...) joined recently". It changes with icon image. In your case it is shield and text "swansont is a moderator".

Link to post
Share on other sites

Hi, @Dave. Great work. Thank you.

I've found some issues though:

1) I always seem to appear in anonymous mode. I've tried clearing cookies, but it doesn't seem to work.

2) I cannot edit my posts anymore

3) Some inline maths don't seem to compile after refreshing

Point 3) seems to be due to introducing by copy and paste in rich-text format. Probably not an issue, but as I wasn't able to edit my comment, I couldn't fix it.

Link to post
Share on other sites
1 hour ago, joigus said:

Hi, @Dave. Great work. Thank you.

I've found some issues though:

1) I always seem to appear in anonymous mode. I've tried clearing cookies, but it doesn't seem to work.

2) I cannot edit my posts anymore

3) Some inline maths don't seem to compile after refreshing

Point 3) seems to be due to introducing by copy and paste in rich-text format. Probably not an issue, but as I wasn't able to edit my comment, I couldn't fix it.

 

Have you found this ?

edit1.jpg.1a415550b41a82fd0f9390ba3771f7cd.jpg

 

 

Voila!

 

edit2.jpg.f3ba32a73ac8bd1f57ae39b01ef3c3bb.jpg

Link to post
Share on other sites
9 minutes ago, studiot said:

 

Have you found this ?

edit1.jpg.1a415550b41a82fd0f9390ba3771f7cd.jpg

 

 

Voila!

 

edit2.jpg.f3ba32a73ac8bd1f57ae39b01ef3c3bb.jpg

No. That must be it. This post will serve me to test. Thank you.

Edit: It is. Thank you

Edited by joigus
editing
Link to post
Share on other sites

@Dave

I now keep messing up an edit (and I see others making the same mistake)

This is because I naturally click on the button just below the bottom right of my post.

This is now the quote button and I start editing that.

Then the automatic merge kicks in when I click save so there is then a double copy.

 

As well as setting a trap for the unwary, like me, It really is an example of inefficient programming.

Two clicks where one formerly sufficed.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.